Toll-free / VOIP Texting Provider Experiencing Message Latency
Incident Report for Teckst
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 23:26 EDT
Identified
Our provider is currently investigating an issue with SMS Latency.
We will provide updates as they become available.

Teckst may face issues when creating new conversations.
Inbound messages maybe delayed.
Posted Sep 08, 2020 - 16:36 EDT
This incident affected: teckstCRM, SMS Carriers, and TeckstAPI.