Toll-free / VOIP Texting Provider Experiencing Message Latency
Incident Report for Teckst
Resolved
The issue is resolved and the system should be running without any delays.
Posted May 21, 2020 - 12:48 EDT
Investigating
Our provider is currently investigating an issue with SMS Latency.
We will provide updates as they become available.

Teckst may face issues when creating new conversations.
Inbound messages maybe delayed.
Posted May 21, 2020 - 10:18 EDT
This incident affected: teckstCRM, SMS Carriers, and TeckstAPI.