Toll-free / VOIP Texting Provider Experiencing Message Latency
Incident Report for Teckst
Resolved
All Toll-free and VOIP traffic appears to be flowing as expected.
Posted Feb 18, 2020 - 22:11 EST
Investigating
Our provider is currently investigating an issue with MMS Message Latency.
We will provide updates as they become available.

Teckst may face issues when creating new conversations.
Posted Feb 18, 2020 - 16:49 EST
This incident affected: teckstCRM and SMS Carriers.