MO/MT Message Latency
Incident Report for Teckst
Resolved
Our provider has resolved this issue. Messaging has been returned to full functionality.

We appreciate your patience.
Posted 7 months ago. Feb 13, 2019 - 14:54 EST
Monitoring
Our provider has implemented a fix and is currently monitoring the issue.
We will keep you posted with the updates
Posted 7 months ago. Feb 13, 2019 - 14:07 EST
Investigating
Our provider is currently investigating message latency affecting MO/MT traffic for landline and toll-free numbers.

Thank you for your patience while we investigate.
Posted 7 months ago. Feb 13, 2019 - 12:07 EST
This incident affected: SMS Carriers.