MO/MT Message Latency
Incident Report for Teckst
Resolved
Our provider has resolved this issue. Messaging has been returned to full functionality.

We appreciate your patience.
Posted 7 months ago. Feb 22, 2019 - 13:40 EST
Investigating
Our provider is currently investigating message latency affecting MO/MT traffic for landline and toll-free numbers.

Thank you for your patience while we investigate.
Posted 7 months ago. Feb 22, 2019 - 13:15 EST
This incident affected: SMS Carriers.