Toll-free Texting Provider Experiencing Message Latency
Incident Report for Teckst
Resolved
This incident has been resolved and we are seeing messages delivered promptly and at normal levels.
Posted 11 months ago. Nov 01, 2018 - 14:18 EDT
Investigating
We have been informed by our SMS provider for VoIP and toll-free numbers that they are experiencing message latency. Messages are being delivered, however, that delivery is delayed. We will continue to update as we receive new information. Please call us at 855-980-6848 or email support@teckst.com with any questions.
Posted 11 months ago. Nov 01, 2018 - 10:04 EDT
This incident affected: SMS Carriers.